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Many-to-one Sweep
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Many-to-one Sweep

e Coreform Cubit is a semi-

automated hex-mesher T
* Means that Cubit can recognize
certain topologies as meshable N

without further decomposition by the
user

S

* A “many-to-one sweep” (N:1) is e
one of the techniques that can ;
recognize topologies as meshable

* Importantly, whenever an N:1 y
sweep is used, you could have done (
additional decompositions to make N 4
multiple 1:1 sweeps
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Many-to-one Sweep

Can result in relatively
poor elements through
the sweep
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Manual decomposition

Webcuts result in “firm”
element boundaries
that can improve
element quality
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Tire tread geometry

Single “unit” of tread with symmetry Full tread pattern
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Separating into subunits

* When dealing with complex
models, it’s often helpful to cut
the model into simpler subunits
and process individually

e Export each subunit to unique
ACIS file

* Process each model to obtain
mesh, save as CUB5

* Import all CUB5 and apply final
operations for global meshability
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Meshing Section 1
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Overview

* This section doesn’t require any
cleanup to produce an N:1 mesh




eshing Section 1

Command Panel

Bz » Mesh » Volume » Mesh » Sweep

Select Volumes

1

© Spedfy Source and Target
() Auto Select Source and Target

Source Surface ID(s) 15117909289 143172

Target Surface ID 19

© Default () Extrude () Advanced

[] Redistribute Nodes

Transform Method Least Squares

Propagate Bias
Parallel Meshing Enabled

Automatically Smooth the Target Surface

Fixed Imprints Smart Smooth

Tolerance 0.2

4k

Mumber of Layers 5

® 9

B check For Overlapping Surfaces
B 2pply Scheme Before Meshing

Apply Scheme

Scheme: sweep Mesh
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Meshing Section 1




” ‘\

{&) coreform

Mesh quality

Note that the poor elements
tend to be caused by “linking”
between sweep layers
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Group assingments

When meshing using this “by-section”
approach, it can be useful to add any
sweep assignments to groups

aaaaaaaaaa

uuuuuuuuu

This will allow for easily reassigning
mesh commands when recombining
all the sections together

When finished save as a CUB5

Do this process for each section
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Meshing Section 2
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Overview

* This section will require a few
composite operations, to
convert challenging-to-mesh
surfaces into simpler topology
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Meshing Section 2

* Many sipes have rounded
features such as shown on the
right

* These pose a challenge for
meshing as the linking curves for
our eventual sweep become
perpendicular to the sweep
direction and form a singularity
between three surfaces
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Meshing Section 2

* Compositing the three surfaces
into a single curve allows Cubit
to ignore the troublesome
topology.

* When placing elements & nodes,
Cubit will still evaluate the
underlying surface geometries
(i.e., shape), just has the
freedom to ignore the topology
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Meshing Section 2

Command Panel g X

.F*F ¥ Geometry ¢ Surface » Modify » Composite

Surface ID(s) &5 &7 64
Select
0O Create () Delete

Max Surface Angle
H Composite Bounding Curves

Keep Vertex ID(s)

Max Curve Angle 15

Virtual Geometry

@ £) Apply
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Meshing Section 2

ecubi‘ J

| Command Panel

H':: b Geometry » Curve » Modify » Composite

Curve IDs 234 235

Select
0 Create O Delete

Keepvertexto [

Max Curve Angle

Virtual Geometry

® 9




Command Panel 8 x
B » Mesh v Volume » Mesh » Sweep
Select Volumes
1
© Specify Source and Target
() Auto Select Source and Target
Source Surface ID(s) 140 142 168 67 154 152 57 16368
TargetSurfaceID 2
© Default () Extrude () Advanced
8 Redistribute Nodes
Transform Method Least Squares
Propagate Bias
Parallel Meshing Enabled
Automatically Smooth the Target Surface
Fixed Imprints Smart Smooth
Tolerance
Number of Layers & :

O 9 Apply Sgheme

B Check For Qverlapping Surfaces
8 2pply Scheme Before Meshing

Scheme: sweep Mesh
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Smoothing

0.995

Command Panel =

# » Mezh » Volume » Smoothing » Condition Number

.759

Volume ID(5) 1
8 set Target Condition Number

22 Condition Mumber 2.0

8 Limit Running Time
Time {minutes) 0.5

0256 JoEs

-0.0495
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Command Panel g x

9 ¢ Mesh ¢ Volume » Quality » Quality Metrics

Volume ID(s) 1

Quality Metric Scaled Jacobian e

Summary Options
© Combined Summary
O One Summary Per Entity

[ Filter Element Quality Range
[ Filter Using Element Quality Rank
B Display Graphical Summary

B Draw Mesh Elements
[] Draw Histogram
[] Monochrome

.0.0926

B Clear Display for Mesh L

D Print Text Summary

@ 0 Apply
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* Note that the sloped surface
results in relatively poorly
shaped elements, but this
element quality isn’t too bad

0.562
-

0.514

. 0.465

* The less perpendicular the
surface, the more elements
need to deform to conform, I
resulting in worse element
quality

0.417
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Meshing Section 3
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Overview

* This section is nearly identical to
the second section, requires
similar processing to produce an
N:1 mesh
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Meshing Section 4
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Overview

* This model has a sliver that was
made to ensure vertical surfaces on
the symmetry surfaces

* This sliver would enforce poor
element quality but we can move
the geometry back to the other
side and make a better “symmetry
cut”

* This, combined with some other
cleanup will then allow us to make
an N:1 sweep
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Initial Cleanup

Command Panel [ 4

a ¥ Geometry » Surface » Modify » Remove

Surface ID(s) 159
B Extend
[ Remove Blend Chain

[:I Remove Cavity

[ ] Keep Surface

[ | Keep Copy OF Original
[] Remove Individually

["] Remove Connected Sets

®© 9 =
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Overview of the new cut

e Goal:

* We want a curve that will allow us
to sweep in the —Z direction,
approximately in-between the two
nearly-vertical surfaces
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Create offset surface

* Step 1.
e Create an offset surface

approximately, will retain the
general shape of the surface

Comman d Panel = 4

@ v Geometry » Surface » Create » Offset

om Surface ID(s) 22

Offset Value 9|
Optional Surface ID{s)/0ffset Pairs
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Create extended surface

* Step 2:
e Create an extended surface,
extended from the offset surface.

* By default the extended surface
extends to extent of total
bounding box — which is why it
was helpful to split the part into
sections

mmmmmmmmmmmm

dddddddddddd
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Webcut sweep curve

* Step 3:

e Sweep the top curve of the
extended surface, in the —Z
direction

mmmmmmmmmmmm

Direction

End Conditions

[ Group Results
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Webcut sweep curve
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Move chopped volume

* Step 4.
e Now we want to move the volume

to the other side of the volume — a
distance 29.42 in the +X direction

aaaaaaaaaaaa

=
-
Volume
B tndude Merged
eeeeeeeeee
© Dis (O ToEnti
O To inates () General Location
() In Direction Of Surface Normal
X Distance 29.42|

YYYYYYYY

ZZZZZZZZ
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Unite into single volume

* Step 5:

* We can then safely unite the
volumes back into a single volume

mmmmmmmmmmmm
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Composite surfaces

* The geometry modification
completed, we now composite
extraneous surfaces into macro
surfaces

e Sometimes can be done as a

aaaaaaaaaaaa

55555555555

eeeee




’i“‘}

[©) coreform

Composite surfaces

* lgnored curves will be shown as
a dashed line
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Generate many-to-one mesh
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Meshing Section 5
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Overview

* The most complicated section,
we need to use all the tools:
1. Rechop to remove sliver feature
2. Geometry cleanup
3. Virtual topology
4. N:1 meshing




P Ay

{) coreform
Chop off the sliver

* We use the same approach as
for section 4 to chop and
recombine the sliver region

* Note here that the offset and
extended surfaces are tall and,
due to their angle, the top curve
isn’t over the desired cut surface
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Chop off the sliver

e So we’ll trim the extended
surface to give ourselves a curve
that we can use for our cut

Comman d Panel g x

'a b Geometry b Volume » Webcut » Coordinate Plane

Volume ID(s) 3
O vz O zx O xv

Offset Value 1|

[ Rotate Plane

I:] Imprint
Include Neighbars

[] Merge

[ Group Results

® 9
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Chop off the sliver

* Then we do our same webcut
approach as before
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Move the chopped surface




’i““}

©) coreform
Recombining & cleanup

e Goal:

 Some CAD modeling errors can be
seen prior to us re-uniting the
volumes

 We want to clean up these
mistakes

* You could ask the CAD designer to fix
in native CAD software

* Oryou can fix yourself using Cubit’s
direct modeling engine
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Chop off extra block

* Create a surface by sweeping the
fillet’s curve in the +X direction

CCCCCCCCCCCC

eeeeeeeeee

Distance 10
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Chop off extra block

* Then we can use a webcut using
the plane of this surface to begin

trimming this region away

Command Fanel

t, k Geometry k Volume » Webcut » Plane Surface

Volume ID{s) 1

Flane From Surface ID 140|

[ Group Results

@ 0 Preview
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Chop off extra block

* Next we chop off the “tower”
part of the block by the plane
defined by the base surface

Command Panel nl
t, k Geometry k Volume » Webcut » Plane Surface !

Volume ID{s) 1

Plane From Surface ID 123
[ Group Results

@ 0 Preview
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Delete the volume & tools

Command Fanel

% » Geometry » Volume » Delete

Volume I0(s) 2346 8§

C] Keep Lower Geometry ;
® 9
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Reunite volumes

Command Panel nl

@ » Geometry » Volume » Boolean » Unite [

Volume I0(s) all

[ Keep Originals
[ Incude Mesh

@ 0 Preview
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Remove sliver surface

& cubit

& cubit

Command Panel

. » Geometry » Surface » Modify » Remove

Surface ID(s) 50|

@ Extend

) Remove Blend Chain
[ Remove Cavity

[ Keep Surface

(] Keep Copy Of Criginal

[ Remove Individually
[ Remove Connected Sets

© 9
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Cleanup extraneous surfaces

* Sometimes these operations result in
nearly-equivalent surfaces that are
only different due to numerical noise

* For example, face normals that are 1e-12
different, so that a “regularize” command
won’t clean them

 When these surfaces will eventually
be shared between the different
model sections, you may choose to
use compositing

 When the surfaces won’t be shared,
you may wish to use the “remove
extend” approach to create real
geometry changes
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Continuing CAD Cleanup

* |t appears that the designer’s
modifications to create the
original repeat unit cell resulted
in a few more errors

* We need to remove the sliver
surface that is caused by the
fillet being cylindrical rather
than conical
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Remove the offending surfaces

& cubit ‘ & cubit — o X

Command Panel

. » Geometry » Surface » Modify » Remove

surface ID(s) 20 49
@ Extend

() Remove Blend Chain

[:] Remove Cavity

[ Keep Surface

[ Keep Copy Of Original
(] Remove Individually

[[] Remove Connected Sets

® 9
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Add a new fillet

 Since Cubit doesn’t have the
ability to directly modify the
original fillet to match the
(nearly) conical shape, we will
instead create a new fillet

* This is changing the geometry,
though very slightly
* The best approach would have

been to bring up these modeling
issues to the original CAD designer
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Remove extraneous surface

e Again, cleanup extraneous

surfaces

* Even though we will be removing
this surface, by cleaning it we will
improve the robustness of
forthcoming operations
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Complete the fillet

e Goal:

 We want to remove the ledge
feature, resulting in a full-length
fillet

* Strategy:

* Create a surface that can be swept
and Boolean subtracted to leave
the fillet
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Complete the fillet

* Step 1:

* Create a minimal plane

Praoject
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Complete the fillet

* Step 2:

* Create a plane surface by
sweeping the curve so that it
extends beyond the outer surface
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Complete the fillet

* Step 3:

e Create a vertex on the target
surface’s outer curve

Command Panel ul
f‘ » Geometry » Vertex » Create » On Curve
Curve 10(s) (L2810
Spedify Location Using
() Fraction () Close To Vertex
O Distance O At Location
O Position O Extrema
O Start O Segments
() Midpaint () Discontinuities
() End © crossing
Cross
O curve
© Surface

Surface ID(s) B4
Bounding

() Unbounded

O iBounded:

O Mear

Pick Color... | default

@ 9
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Complete the fillet

* Step 4:

 Partition the target surface
through the two vertices

Command Panel n'

B4 » Geometry » Surface » Modify » Split

Through Vertex v~

Surface ID(s) 46

Through Vertex ID{s) 108 114]

© 9 Previen
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Complete the fillet

* Step 5:

* Create a volume by sweeping the
target surface along the outer
curve

Surface ID(s) 55

() Perpendicular () Target Volume
© Along Curve () Target Plane
() along Vector () About Axis
() Direction () Helix

Curve ID(s) 145|

B individual Volumes
[ Include Mesh
[] Merge Results
| 8 Delete Guide Curves
[ Delete Source Surfaces

® 9
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Complete the fillet

* Step 6:

* We suspect that there will be
small CAD features introduced if
we were to Boolean subtract, so to
minimize we extend the volume to
at least remove one potential

.
Command Panel n,
] -
&9 » Geometry » Volume b Modify » Extend by Sweep
Note: This panel hed ry only.
Surface ID(s) 59
() Perpen dicular () Target P lane
() Along Curve () About Axis
© along Vector () Hel
O Direction

Vector ¥,¥,Z 100

Distance (Optional)
(] Draft Angle [ rigid

(] Draft Type Extend Round

D 9
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Complete the fillet

* Step 7:
e Subtract the tool volume

* This leaves a little pocket which
we will need to cleanup
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Complete the fillet

Overview of pocket Detail

Small CAD surfaces from
the resulting pocket
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Complete the fillet
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Takinq stock of progress

Need to remove ledge
from other side
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Reviewing symmetry model

Need to remove ledge
from other side to
recover symmetry
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Recovering symmetry

e Goal:

e Recover symmetry by making the
ledges on both sides match
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Recovering symmetry

* Step 1:
* Create copy of the target curve on
our current working surface

eeeeee
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Recovering symmetry

* Step 2:
 Use the two vertices from the new

curve and one vertex on the
original curve to define a cut plane

Command Fanel n]

g b Geometry b Volume b Webcut » Plane Vertex

Volume ID(s) 1

Vertex 11D 148

Vertex 2ID 147

Vertex 31D 105

[ Group Results

@ 0 Preview
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Recovering Symmetry

* Step 3:
* Begin chopping off the region to
remove, here extending one of the

base surfaces

Command Fanel n]

a« Volume » Webcut » Sheet Extended From Surface

Volume ID(s) 1

With Surface ID(s) &5|
[ Group Results

@ 0 Prewview
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Recovering Symmetry

* Step 4:

* Continue chopping off the region
to remove, here extending other
base surface

Command Fanel n]

a« Volume » Webcut » Sheet Extended From Surface

Volume ID(s) &

With Surface ID(s) 113

[ Group Results

@ O Preview
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Recovering Symmetry

* Step 5:
e Subtract the extraneous volume \ _—
* Step 6:

e Unite the volumes




,i‘““

{) coreform

Recovering Symmetry
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Meshing Section 5

* Now we have finished fixing the
geometry

* Next, we will go through the
model and composite surfaces
to support a quality mesh
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Result of compositing
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Meshing Section 5

* While we could build an N:1

mesh on the remaining volume,
there’s enough source surfaces
that it makes sense to split into
three sections to make things a
bit more manageable

* Also provides a little bit of
rigidity to the mesh that helps
with robustness and quality
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Meshing Section 5

* Step 1:
* Apply “Sheet Extended From
Surface” webcut, using 2 surfaces

* The resulting webcut will use the
trimmed extensions of these
surfaces (note the angle)

Command Panel n]

’a« Volume » Webcut » Sheet Extended From Surface

Volume ID(s) 1

With Surface ID(s) 8 29

[ Group Results

@ 0 Preview
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Meshing Section 5

* Step 1:

* Apply “Sheet Extended From
Surface” webcut, using 1 surface
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Meshing Section 5
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Recombine and Create
Unified Mesh
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/Note that these meshes are not contiguous
at their boundaries. We will need to imprint
and merge these volumes with each other

and remesh! P
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Create Contiguous Mesh

N

After imprinting and merging, we reapply
the sweep schemes using the groups we

e

created along the way.
Now we have a contiguous mesh!

)

AU
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efining the mes

Command Panel n]

2 » Mesh » volume » Refine » General Refinement

Volume ID(s) all

Refinement Condition

© split Tterations 1

() Target Size 1

Bias 1.0

Refinement Boundary

© Element Depth 1

() Refinement Radius 1

Apply

N

While you could use a finer mesh size at
the time of creation, | find that sometimes
it's faster and more robust to mesh coarse

and then refine to the desired size —
especially when using N:1 sweeps
0 P y g p )
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Reviewing the model
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Reviewing the model



’i“‘}

Y coreform

\"

Reviewing the model
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